Facilitating Stakeholder Reviews:

Using Start Pages, Guides and Comments

An iRise project is only as good as the feedback and collaboration it generates. While building great simulations is one key step in making this happen, there are a number of additional steps you can take that will ensure a great reviewing experience for your stakeholders. And in the world of software visualization, engaged stakeholders lead to productive review cycles.

Watch a Video

Watch this video for a demonstration of the topics covered in this tutorial.

Gauging the right level of support for reviewers

Project reviews can take place under a wide variety of circumstances. One organization's idea of a productive environment for collaboration might look completely different from that of another organization, and environmental constraints might make it impossible for either organization to collaborate in their ideal setting.

Live Review meetingSelecting the right mix of reviewing features in your iRise projects, and deciding how much scaffolding to provide to your reviewers, is a process that needs to happen separately for each of your projects. While some organizational standards might be implemented (e.g., start page templates), certain factors such as geographic dispersion of project teams and intended uses of your simulation still need to be considered.

This analysis of the project environment will often dictate the manner in which you use the tools discussed below. To the extent possible, we'll provide some tips to help guide not just the mechanical aspects of their use, but also your selection of the right tools for the job.

Using a start page to orient your reviewers

The start page is the first page that your reviewers see when they launch your simulation from a Definition Center or an iDoc. You can use this feature to your advantage by creating a start page that provides key information that will enhance the reviewer's experience and improve your chances of getting the feedback you need. Your start page can also serve as a "splash page" for your simulation, providing an attractive, inviting introduction to your project.

SimWealth start page

Setting your project's start page is easy:

  1. Select the view, Simulation or Document, in which the simulation should begin by choosing the corresponding tab.
  2. In the Directory panel, right-click the desired chapter and choose Start Page.

A small green dot will appear to the left of the chapter's name in the Directory. Remember that your selection only affects the simulation when launched from a Definition Center or an iDoc. Launching your simulation from within Studio will still open whichever chapter is currently displayed in your workspace.

As you design your start page, keep the following recommendations in mind:

  • Since your start page is the first page your reviewers will see, appearance matters. Consider branding it with your company or division logo, and styling it in a manner that is consistent with your organization's design standards.
  • Depending on your stakeholders' experience level with iRise simulations, you might want to provide a brief explanation of the reviewing process, and possibly links to a job aid or an online tutorial.
  • Setting expectations is one key to getting actionable feedback. Providing a brief explanation of the simulation's goals and its context within a larger project or development effort can help with this. You can also specify which areas of the simulation should receive the most attention.
  • Provide a link to begin reviewing the simulation. If you have multiple scenarios, you can provide a link to each one along with a clear description of the scenario's goal (make sure you also provide navigation back to the start page from each scenario).
  • As an optional enhancement, you might consider building some integrated support or admin tools within your project and linking to them from your start page. Some possibilities include a change log, a contact list and a list of references.

The SimWealth, SimBank and SimRetail iDocs in the Simulation Resources area of iRise.com each provide a good example of a start page that you can use as inspiration or a template for your own start page.

Using Guides to facilitate stakeholder reviews

When you can personally lead a review session, everyone benefits from your ability to navigate through the scenario exactly as you intended. You can show what needs to be shown, and get exactly the feedback you need.

When your simulation will be reviewed remotely, however, you have little control over the path your reviewer takes through a scenario. That is, you have little control unless you make use of Guides.

Guide in the ReaderGuides are annotations that you can add to your pages in iRise Studio. They can be toggled on or off in iRise Reader so they appear only when they are needed, and can be used to provide any type of information to supplement the simulation itself. Common uses for Guides are to provide walkthrough notes to reviewers, specific instructions for interacting with the simulation, or background information pertinent to the page being reviewed.

Guides can be configured to display whenever a page loads in the Reader, or they can be associated with specific content on the page so they are revealed when the reviewer mouses over the content. They can also be configured so they display only when the page is viewed in the context of a particular scenario so you can provide information relevant to that scenario.

Guides in Studio

Adding a Guide to a page is as simple as dragging the Guide icon from the Widget Toolbar to the page's canvas, and then typing the Guide content in the Properties panel (shown above). To associate the Guide with a specific widget on the page, just drag the Guide icon from the canvas and release it on the widget. The association will be indicated in Studio by a pale yellow line connecting the Guide icon with the page widget.

Tip
You can display the contents of your Guide in Studio by double-clicking the Guide icon on the canvas.

Managing stakeholder feedback

Whether you conduct stakeholder review sessions in a live meeting or asynchronously, the integrated commenting features in iRise are a powerful tool for recording and managing the feedback you receive from project stakeholders. Comments added to a project either in Studio or iRise Reader are automatically associated with the page or scenario to which they were added, and can even be associated with specific content, ensuring that feedback is on-target and never taken out of context. Comments from multiple reviewers are seamlessly aggregated within your project, and if your project is on a Definition Center, those comments are viewable in Studio in real time.

Adding a comment

Adding a comment to a project is extremely simple, and differs only slightly between Studio and the Reader:

  • While working in Simulation View in Studio, you can add a comment to any chapter type except for a datasheet by right-clicking anywhere in the workspace and choosing Add Comment from the context menu. In Document View, you can add a comment to any requirement using the same method.
  • Adding a CommentTo add a comment in iRise Reader, click the Add Comment button in the status toolbar. To associate the comment with a specific widget or requirement, click the Associate to Widget link in the Add Comment box, move your mouse over the desired object until it is highlighted, and then click the object. When you click Save, the comment will be added to the project and viewable in the Comments panel. What happens next will depend on whether the simulation was launched from an iDoc, Studio or a Definition Center.

Managing Comments

Comments that are added to a simulation that was launched from Studio or a Definition Center automatically become part of that project, and can be viewed by anyone with access to the project both in Studio and on the Definition Center. Comments added to a simulation that was launched from an iDoc must be imported into the project in Studio after the reviewer sends the iDoc back to the modeler (File > Import > Comments).

Comments Panel

Once the comments are embedded within the project, they become a key part of your modeling workflow, with each of the following features and capabilities adding to their usefulness:

  • View comments - The Comments panel is available both in Studio and the Reader, and can be revealed either from the View menu or by clicking the Comments button in the status toolbar. Clicking any comment either in Studio or the Reader will take you to the chapter and, if applicable, highlight the widget with which it is associated.
  • Filter and sort comments- The Sort menu in the Comments panel allows you to sort on one of six different fields, and the Options menu gives you the ability to filter your view so that only open comments and/or comments associated with the chapter you currently have open are displayed.
  • Open, close or delete comments - You can toggle the status of any comment either in Studio or the Reader by clicking the checkmark icon to the left of the comment. Closed comments are easily recognized by the crossed/grayed out text and the darkened checkmark icon. Comments can only be deleted in Studio (right-click and choose Delete). Keep in mind that this action is permanent.
  • Flag comments with a color - You can color-code comments according to whatever internal standard you put in place by clicking the small circle just to the right of the checkmark icon. A reviewer can also do this in the Add Comment box while adding the comment.
  • Export comments to CSV - You can export comments to a comma-separated values (CSV) file so you have an external record of project feedback or for distribution to stakeholders who don't have access to the simulation. In either Studio or the Reader, choose Export > Comments from the File menu or from the Options menu in the Comments panel.