Adding Text Requirements

There are many circumstances that might call for the addition of Document Text to a simulation. You can use this text, commonly referred to as “requirements,” to annotate the simulation with specifications, narrative text, use cases, or any other text that helps you define your application. Your stakeholders can then review and comment on these requirements in iRise Reader.

Whether you use Document Text to write traditional system requirements, as an informal note-taking tool, or something in-between, the ability to incorporate it seamlessly into your project deliverables can increase the value of your work, while decreasing the burden of visualizing every functional requirement in scope for your application.

This tutorial will get you up and running with Document Text. You’ll learn how to write, format and move requirements in iRise, add hyperlinks, search and run a spell check, associate requirements to page widgets, and view requirement attributes. The more advanced requirement synchronization capabilities will be covered in a later tutorial.

Watch a Video

Watch the following video for a quick demonstration of the concepts covered in this tutorial.

What is Document Text?

Text requirements that you add to your simulation in Document View while working on any of your project components is called Document Text. These requirements are automatically associated with the component (page, scenario, etc.) in which you are working, and can be organized in either a flat or nested hierarchy. The impact of viewing requirements in the context of your visualizations can be deepened even further by associating individual requirements with specific simulation content.

Document Text

While the Document Text editor does have some limitations, overall it is a versatile tool that provides the following capabilities:

Writing requirements

To create requirements for a project component in iRise Studio, switch to Document View while the component is displayed in your workspace. The Document Text editor will appear beneath a static image of any screen content.

Click below the image, beneath the last requirement on the page, or between two existing requirements to insert a new requirement. When your cursor is blinking, just start typing. To add a second requirement, click below the previous requirement, or while the requirement is in edit mode, press Ctrl-Enter to add a new requirement directly beneath it.

While a requirement is selected, you can click the arrow icons that appear on the right side of the requirement to indent or outdent as necessary. Indented requirements are prefixed with a number based on the chapter number (shown in the chapter title) and their position in the requirement list.

Editing a requirement

Selected requirement

Tip

An extensive set of keyboard shortcuts is available for working in the Document Text editor. See the iRise Help System for more information.

Moving requirements

You can move one or more requirements either within a chapter (Directory component) or to another chapter. To move a requirement within a chapter, right-click it and choose Move Up or Move Down from the Move submenu. To move one or more requirements to a different chapter, right-click the selected requirement(s) and choose Move > Move To. In the Move dialog, select the destination chapter and click the Move button.

In either case, if you move a requirement that has any children in the requirement hierarchy, they will be moved along with the parent.

Tip

To select a requirement without switching to edit mode, click the “handle” on the left edge of the requirement. To select multiple requirements, hold down the Ctrl key while making your selections. You will also use the handle when dragging requirements either to move them or associate them with page widgets (see below).

Associating requirements to page widgets

You can add context to your requirements by associating them to page widgets. For example, if you write a requirement about the style of a submit button, you can associate that requirement to the submit button on the screen reference in the document. This creates traceability from the textual to the visual domain.

Requirement associations

To create an association between a requirement and a widget:

  1. Select the requirement.
  2. Click the handle for that requirement (i.e., the gray bar on the left side of the requirement) and drag it on top of the screen shot.
  3. Release the drag on top of the widget to which you want to associate the requirement.

Superscript letters and gray lines (when the requirement is selected) show the relationship between requirements and associated widgets.

Tip

You can also associate requirements to elements in scenarios (e.g., pages, clouds, decisions); however, when writing scenario-level requirements, be sure to write them at the correct level of detail. Highly detailed functional requirements should be reserved for the chapters in which those requirements are being defined.

Adding links and formatting your requirements

You can add hyperlinks to your requirements using a standard Link widget. Just select a span of text, right-click and choose Add link. The Set Destination dialog will appear, enabling you to create a link to another page in your simulation, to an external web site, or to an embedded file. You can also configure the link to open a new email message.

You can modify the text formatting of your requirements using any of the controls available in the Formatting Toolbar, including font type, color, size, background color and bold/italic/underlining.

Expert Tip

The local formatting you apply in Document View will not show up in the exported requirements document, since the styles mapped to the document template override local formatting. You can preserve some formatting in the exported document by modifying the styles that are automatically applied to requirements in Document Text.

Searching and spell-checking requirements

You can search Document View in Studio for a particular requirement using the requirement ID or a phrase as the search criteria. Choose Edit > Find Requirement to open the search dialog.

To spell-check your requirements, choose Spell Check (Document) from the Tools menu in Studio (v8.8 or later – in earlier versions this command was under the Edit menu).

Viewing requirement attributes

Requirement details, such as the requirement ID, creation date or any other attribute, can be viewed in Studio or the Reader.

Requirement attributes pop-up

In both cases, if you have added any attributes to the requirement via iRise Connect or CSV Import, the imported attributes will also appear in the Requirement Details pop-up.

Notes chapters

Notes chapters, which can only be edited in Document View (and therefore can only contain Document Text), can be added to your project if you need to include textual information that does not relate directly to the visual components of your simulation. You might take advantage of this feature to record project overview information, maintain a change log, or provide a general note-taking tool as you work on the project. If you open a Notes chapter in Simulation View in iRise Reader, you will be prompted to switch to Document View.